
 

A Quick Guide to Creating Web Pages 
 
A basic working knowledge of HTML tags will allow you to create simple web pages using any text 
editor. HTML is composed of a number of opening and closing tags that direct the appearance and 
behavior of the text in an HTML document. Tags are set off with angle brackets and enclose the text 
you want to affect: <p>. A forward slash always precedes the ending tag: </p>. All tags should be in 
lower case. 
 

Example:  You want to bold type the phrase “petit 
chou”  
 
 You type in HTML:   <strong>petit 
chou</strong> 
 You will see in your browser:  petit chou 

 
 
 
 
 
 
 
 
Some possible html editors you can use are Notetab Light or Web Media Publisher Pro. These have 
helpful features to save time and typing as you code. A plain text editor like Notepad requires 
everything to be done by hand and without color coding. There are also applications like Macromedia 
Dreamweaver that are known as WYSIWYG (what you see is what you get) editors. These allow you 
to build pages using a visual interface rather then straight code. However, you can choose to use 
Dreamweaver as an text-based editor by switching to the code view.  Using the visual design view is 
not be the best way to learn the “nuts and bolts” of html. Pages created using the design view may 
appear differently when uploaded to the web.   
 
Once you’ve created your files, you will use an FTP client like WinSCP to put them on the server 
making them available on the web. 
 
There are lots of sites devoted to free HTML information and free design tools on the web.  Here 
are a few tutorial-type sites to explore: 
 
Dave Raggett’s Introduction to HTML from the W3C:   
 http://www.w3.org/MarkUp/Guide/ 
Candy Schwartz’s Tutorials et al: 
 http://web.simmons.edu/~schwartz/web.html  
Beginner’s Glossary and Guide to HTML:   
 http://www.lehigh.edu/~kaf3/guides/kenhtml.html 
Bare Bones Guide to HTML (multi-lingual):  
 http://werbach.com/barebones/    
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Designing Attractive Web Pages:   
 http://wdvl.internet.com/Authoring/Design/Pages/  
Intermediate HTML:  
 http://www.washington.edu/computing/training/510/ 
 
And a few design sites: 
 
Web Clip Art Home Page:  
 http://webclipart.about.com/ 
Web Monkey Graphics Tips 
 http://webmonkey.wired.com/webmonkey/design/graphics/ 
Optimal Web Design 

http://psychology.wichita.edu/optimalweb/ 
 
BEFORE YOU BEGIN – A FEW FREQUENTLY ASKED QUESTIONS 
 
Where is my web space? 
Every student automatically has space for a web site on the Simmons server.  You may see this server 
under 2 names, web.simmons.edu or joan.simmons.edu.  These are two different names for the same 
server. 
 
How do I get my files on the web? 
To make your files from your choice of local storage media (such CD, flash drive,  or hard drive) you 
must send the files via FTP from your local storage media to the server. 
 
What is FTP? 
FTP, an acronym for File Transfer Protocol, is used for transferring files over the internet.  It will help 
you get your local files onto the Simmons server. 
 
How do I use FTP to send a file to my web space? 
Every machine in the GSLIS Tech Lab has a program called WinSCP installed.   For instructions on how 
to use WinSCP, see the Using FTP and Your Simmons Web Space handout at 
http://my.simmons.edu/gslis/techlab/docs/FTP.pdf. 
 
How do I scan my photos? 
For instructions on how to scan photos in the GSLIS Tech Lab, see the Scanning Images handout at 
http://my.simmons.edu/gslis/techlab/howto-info.shtml. 
 
I’ve got scans of my photos, now what? 
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Now you want to make them into a web-readable format.  This entails resizing them, setting the 
resolution to 72 ppi (pixels per inch) and saving them into the .gif or .jpg format.  For more 
information on this visit http://my.simmons.edu/techlab/howto-info.shtml and click on the Adobe 
Photoshop Basics handout. 
 
What’s the difference between a .jpg and a .gif file? 
The JPEG file format, which uses the .jpg file extension, is used particularly for photographs, while the 
GIF format, which uses the .gif file extension, is limited to 256 colors, and is best used for text images 
and illustrations.  For more detailed information about the differences between these two file formats, 
please see Webopedia’s “Did You Know…?” article on image file formats 
(http://www.webopedia.com/DidYouKnow/Internet/2002/JPG_GIF_PNG.asp). 
 
I don’t really know how to use Adobe Photoshop.  Where can I find some help? 
A good start is the Adobe Photoshop Basics handout.  Also, try using the Help menu within 
Photoshop to search for answers to some of your questions. 
 
For more detailed instructional information, you can also check out Webmonkey’s Photoshop 7.0 
Overview (http://hotwired.lycos.com/webmonkey/02/16/index1a.html) 
OR 
Webmonkey’s Photoshop 7.0 Crash Course 
(http://hotwired.lycos.com/webmonkey/design/graphics/tutorials/tutorial1.html). 
 
How do I add text to an image in Photoshop? 
If you would like to add text to your image, click on the "T" in the toolbox, which activates the Text 
tool, then click into your image and start typing.  This creates a text layer which can be moved and 
manipulated separately from the rest of the image.   To alter the font, color, style and appearance of 
your text, select the text layer from the Layer toolbox and highlight the text with your mouse. This 
will enable the text tools on the top toolbar. You can also go to Layer > Layer Style and for additional 
effects. 
 
 
 
 
 
 
BASIC HTML STRUCTURE 
 
An HTML document is composed of the head (containing information about the document) and the 
body (containing the text and images that appear on the browser). Before the head, however, it is 
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important to put the DOCTYPE declaration (describing the version of XHTML you are using), and the 
HTML element with the xlmns attribute.  Ex:
 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "DTD/xhtml1 
transitional.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> 
 
<head>    
<title>The Chou Page</title>   [This title info appears as The Chou Page in the browser’s  
</head>    blue title bar and in bookmarks.] 
 
<body>    [Enter all text between the body tags.  This info – text, 
Chou means cabbage in French.  links and images - will appear on your web page.] 
</body> 
</html> 

 
SOME BASIC TAGS 
 
<strong> </strong> Makes the enclosed text bold. 
<em> </em>  Italicizes the enclosed text. 
<h1> </h1>  Creates a heading (you can also have h2/3/4/5, etc.) 
<p> </p>  Paragraph tags enclose each paragraph of straight text. 
<br />   Creates a line break (note the space before the slash).  
<hr />   The hard rule produces a narrow bar across the page. 
  
The line break and hard rule are self-contained, which means that they open and close themselves by 
means of the space and slash. 
 
TABLES 
 
Within the body, you can use tables to organize information. You can also use tables without a grid or 
border to align text or images for a cleaner and more aesthetically pleasing web page. A table contains 
at least one row; each row contains at least one cell of text or image. 
 
 
 
Basic table: 
<table> Begin with this tag.  Signals a table. 
<tr>   This tag begins a row. 
<td>  Here, enter desired text, links, or images for first cell.  
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</td>  This tag ends the first cell.   
<td>  Here, enter desired text, links, or images for second cell. 
</td>  This tag ends the second cell. Each <td></td> tag adds another cell to this row. 
</tr>  This tag ends the row.  Each successive <tr></tr> creates another row. 
</table> This tag signals the table’s end. 
 
Notes on tables:  
 

• Webmonkey has an excellent set of easy-to-follow tutorials on Tables 
(http://hotwired.lycos.com/webmonkey/authoring/tables/index.html), including everything from 
the basics to making your tables really efficient, once you get the hand of it. 

• To expand the table over the entire page, write <TABLE WIDTH=100%>  
• To create a borderless table, insert border=“0” within the table tag.   

Ex.  <table border=”0”> 
• To align text/image within a cell, insert align=left (or middle or right) or valign=top (or middle 

or bottom) into the <TD> or <TR> tag.  
Ex.  <td align=right>your cell info here</td> 

• To add a header to a row or column, insert the tag <th>your header title</th> in place of a 
<td></td>; the substitution merely bolds the enclosed text, lending it that “header” look.   
Ex. <tr><th>your header</th> 

       <td>cell info</td> 
<td>next cell</td></tr> 

• Sizing and spacing: The width of a space between cells is called “cell spacing.”  The amount of 
space between data and its cell wall is called “cell padding.”  To define a uniform cell size for 
the entire table, insert cellspacing=n and cellpadding=n (where “n” equals # of pixels) into the 
<table> tag. The default setting is cell spacing=2 and cell padding=1 pixel.  
Ex.   <table cellspacing=”5” cellpadding=”5”>. 

• An easy way to troubleshoot a table is to set BORDER=”1” in the TABLE tag.  This way, you 
can see where the content is located in the table, and compare it to where it should be.  Be 
sure to set BORDER=”0” when you’re done troubleshooting. 

 
 
 
 
 
 

 
LISTS 
 
Lists are another useful way to display information and they come in several types: unordered (items 
with bullets); ordered (numbered items); and definition (items with indented description). You can nest 
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one list within another, but complex nesting can be difficult to follow and edit in HTML. For the basic 
list, the default bullet is a solid dot. 
 
unordered list:  <ul>Begin list with this tag.  ordered list:   <ol>  
(bulleted) <li>First item.</li>   (numbered) <li>First iem.</li> 
  <li>Second item, and so on.</li>   <li>Second, and so on.</li> 
  </ul>End list with this tag.    </ol> 
 
definition list: <dl>Begin list with this tag. 
(indented) <dt>Insert definition term here (or whatever text)</dt> 
  <dd>Text placed here will be indented beneath the definition term.</dd> 
  </dl>End list with this tag. 
 
LINKS 
 

Also known as anchors, hypertext links, hyperlinks, or clickable images.  The basic tag for this is the A 
tag, or anchor tag, with the HREF, or hypertext reference, attribute.  Here are some examples: 
 
In order to link to…   Type:  
 
An external web site:    <a href=“http://(etc.)”>Clickable link name</a> 
 
Another page in your directory:    <a href=“yourfile.html”>Clickable link name</a> 
 
Another place within the same page: You must create the anchor itself (the link on which to click), as 
well as a “place-holder tag” (the place to which the link will jump). 
 
Create a place-holder tag around the requested text.  This text will not be visible on your web page; 
you will see the place-holder tag only in your HTML source code.    
 

Anchor tag: <a href= “#holder name”>Clickable link name</a> 
(Note:  Precede the name of the placeholder tag with the # sign. Be sure to use the identical holder 
name or the anchor won’t be able to “find” the place-holder.) 
 

Place-holder: <a name=“holder name”>Word to which to jump</a>   
  
A specific place in another page within the same directory:  You must create the anchor itself (the link 
on which to click), as well as a “place-holder tag” (the place to which the link will jump). 
  
 Anchor tag: <a href= “yourfile.html#holder name”>Clickable link name</a> 
   (Note:  Precede the name of the placeholder tag with the # sign.) 
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 Place-holder: <a name=“holder name”>Word to which to jump</a>   
   (Note:  Employ identical place-holder names.  No # sign here.) 
 
A specific place in another directory: You must create the anchor itself (the link on which to click), as 
well as a “place-holder tag” (the place to which the link will jump). 
  
 Anchor tag: <a href= “http://URL#holder name”>Clickable link name</a> 
   (Note: Precede the name of the placeholder tag with the # sign.) 
 
 Place-holder: <a name=“holder name”>Word to which to jump</a>   
   (Note:  Employ identical place-holder names.  No # sign here.) 
 
Linking an image to a web page/image: 
The basic tag for this is the A tag, or anchor tag, with the HREF, or hypertext reference, attribute.  
Here are some examples: 
 
Link an image to another page in your directory: 
<a href=" your_file.html"><img src="other_image_name.gif" /></a> 
or 
<a href=" your_file.html"><img src="other_image_name.jpg" /></a> 
 
Link an image to another image in your directory: 
<a href="image_name.gif"><img src="other_image_name.gif" /></a> 
or 
<a href="imagename.jpg"><img src="other_image_name.jpg" /></a> 
 

• NOTE: Links that don’t work can almost always be 
attributed to incorrect tagging. 

• Have you forgotten any end tags? 
• Have you forgotten the quote marks enclosing the URL or 

file name for a given link or image? 
• Have you correctly referred to the image, URL or file?  

Names are case-sensitive.  
Ex: "SmYthE.htm" would not be found if you typed 

"smythe htm"

 
 
 
 
 
 
 
 
 
IMAGES 
 
GENERAL NOTE: 72 PIXELS = ONE INCH  (VGA monitor) 
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• Images load faster if their dimensions are specified. Define image pixel height and width in the 

image tag.  
• Ex: <img src=“your-image-name.gif (or .jpg)” height=“175” width=“50” /> 
• Keep your images under 20k in size – your page will load faster in the browser. 
• Download images from the web by placing the cursor on the image and clicking the right mouse 

button.  Choose “save image as.”  You may change the name of the saved image, but you must 
keep the same extension. (.jpg, .gif) 

• To convert images to .jpg or .gif format, use Adobe Photoshop (see Adobe Photoshop Quick 
Guide at http://my.simmons.edu/gslis/techlab/howto-info.shtml).   

• When scanning images, set the ppi (pixels-per-inch – sometimes incorrectly referred to as dpi 
which refers to printing) to no more than 72 to keep file size small. 

• Always specify an alt to describe image contents for LYNX and screen readers for visually 
challenged users. 

• Ex:  <img src=“house.gif” alt=“My house”/> 
• Consider choosing black and white photos for smaller file sizes.  
• Concentrate on content; clean and simple graphics look best. Animated images can easily be 

annoying. 
 
Clickable images: Whether you choose to link a thumbnail image to its larger counterpart or link an 
image to another page, utilize this basic form: 
 
<a href=“URL to which the image should link”><img src=“image.jpg(.gif)” /></a> 
 
 
IMAGE MAPS 
 
Image maps allow you to assign different links to different regions of an image. For an example, see 
http://www.december.com/html/demo/imagemap.html.  
Note the different pages that you can access by clicking on the different sections of the image. Look at 
the source code (View Menu > Page Source).  Just after the <body> tag is a series of codes describing 
the coordinates of rectangles. That is the map information generated automatically by the map 
software. 
 
It's a good idea to have the map thoroughly planned out before you start.  Use IMAGEMAP or 
MAPEDIT to create clickable areas (hotspots) on an image. Launch either program, open the HTML 
page in which you plan to use your image map, then open the image (.gif, .jpg, .jpeg, etc) that will 
become your map. You should now be looking at your image. You can use the shapes on the drop-
down menus to define the clickable areas on your image.  After you draw an area on your image, the 
software will prompt you to provide your link and your <alt> text for the place to which you would 
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like the hotspot to jump.  Fill out all information then click OK.  You can continue to add areas and 
links until your image is full – then go to File > Save.   
 
If you open your HTML file you will now see an entry at the bottom of the page that gives coordinates 
for your IMAGE MAP.  The following is an example with TWO hotspots: 

  

<map name="Castle2"> 
<area shape="rect" alt="You chat too much!" 
coords="168,47,237,74"  
href="http://www.blahblah.com" title="You chat too 
much!"> 
<area shape="circle" alt="YAHOO!" coords="117,80,0" 
href="http://www.yahoo.com"  
title="YAHOO!"> 
<area shape="default" nohref> 
/

 
 
Please note:  If you plan to validate your pages with the W3C validator, you must add an “id” attribute 
to your image map.  Using the code above as an example, you would alter your code to read:  <map 
name="Castle2" id=”Castle2”>.  The words you choose for the id are not important, but it is good 
coding practice to be consistent with the map name. 
 
Having Trouble?  A Few Tips: 
 
If I try to open my style sheet (.css) file using File > Open in Notetab Lite or Web Media Publisher, I 
can’t see it.  Where did it go? 
These HTML editing programs see the .html file extension by default.  However, some HTML editing 
programs do not see the .css extension by default.  To fix this, when you go to File > Open, and the 
dialog box appears, at the bottom of the box next to “Files of type:”, choose “All files (*.*)”.  You 
should then be able to see and open your .css file. 
 
Once my HTML pag(es) are done, how do I validate? 
Most students use the validators listed on Candy Schwartz’s Web Authoring Coding page 
(http://web.simmons.edu/~schwartz/web.html), to validate HTML pages. 
 
The HTML validator tool gave me a list of all sorts of problems.  What’s wrong? 
Troubleshooting the HTML validator results can be a very difficult part of your project.  We 
recommend that you start your project as soon as possible, and validate your pages as you create 
them, to give yourself plenty of time to fix any validator-found issues. 
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Here is quick list of troubleshooting tips: 
 

1. Check the help documentation for the validator:  the W3C MarkUp Validation Service has a 
useful documentation center of help guides (http://validator.w3.org/docs/), and the Web Design 
Group HTML Validator has a very useful set of help links on its home page 
(http://www.htmlhelp.com/tools/validator/).  Take a few minutes to skim these documents 
before you use the validator, and refer to the help documents after you validate to see if they 
can help you. 
 

2. Read the errors messages carefully:  on first read, many of these error messages may see 
somewhat nonsensical.  However, you may be able to piece together the problem simply by 
reading the error message carefully, then checking the section of the code that is in error. 
 

3. Check your spelling and punctuation:  you may have spelled a tag name or attribute or value 
incorrectly, or you may have added in or left out letters, quotes or other characters. 
 

4. Make sure your tags have the right attributes:  you may have given a tag an attribute that it 
doesn’t use. 
 

5. Make sure that everything opened is closed:  if you open a tag, you must have a matching 
closing tag somewhere.  Even stand alone tags like the IMG tag have built-in closers, with the 
slash inside, e.g., <IMG SRC=”filename.gif” />. 
 

6. Check the order in which your tags open and close:  If you have a set of tags that are ordered 
“<B><I><U>”, then they must close in the right order, “</U></I></B>”.  If you close them in a 
different order, the validator may give you an error. 
 

7. Ask your classmates:  one of the best ways to learn HTML code is by trial and error.  Your 
classmates are an excellent resource, since they may have had the same problems, and may be 
able to help you with their knowledge. 

 
 
 
 
 
I uploaded my HTML file, but I can’t see the pictures.  What’s wrong? 
In order for your pictures to show on your web page, you must make sure that your pictures are also 
uploaded to the server.  When you FTP your HTML files to the server, be sure to include any pictures 
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that appear on any of your web pages.  Also, make sure that the file directory structure you have set 
up on your local copy matches the file directory structure on the server. 
 
My site is uploaded, how do I see it? 
The URL to your web space follows this model: 
 
http://web.simmons.edu/~username/ 
 
Substitute the “username” with the username that you use to log into your email account, and that is 
the base URL to your web space.  Make sure that the home page of your site is named “index.html”.  If 
you do not have an “index.html” file in your public_html folder, you will see the directories inside your 
public_html folder. 
 
Books for Further Reading 
 
Web Design in a Nutshell by Jennifer Niederst 
 
HTML for the World Wide Web with XHTML and CSS: Visual QuickStart Guide, Fifth Edition by 
Elizabeth Castro 
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